Интеграция с Google Sheets

1. Подключение к данным CoMagic через коннектор-скрипт Google Sheets

2. Обработка ошибок

3. Подключение к таблице через PowerBI

4. Подключение к таблице через Google Data Studio

5. Подключение к таблице через Excel

6. Подключение к таблице через Tableau

7. Подключение к таблице через QlikView

8. Подключение к таблице через QlikSense

Вы можете передавать данные из CoMagic в привычный инструмент Google Sheets для их дальнейшей обработки и составления отчетов в BI-системах.

Сделать это можно с помощью нашего коннектор-скрипта.


Благодаря коннектору можно получать:

  • звонки — данные, возвращаемые методом get.calls_report;
  • чаты — данные, возвращаемые методом get.chats_report;
  • заявки — данные, возвращаемые методом get.offline_messages_report;
  • цели — данные, возвращаемые методом get.goals_report;
  • все обращения — данные, возвращаемые методом get.communications_report;
  • статистику по рекламным кампаниям — данные, возвращаемые методом get.campaign_daily_stat.


Подключение к данным CoMagic через коннектор-скрипт Google Sheets

Чтобы начать использовать коннектор, откройте файл CoMagic Data. При клике на ссылку откроется пустая таблица с доступом только на просмотр.

  • Скопируйте таблицу к себе на Google Drive.

  • Введите название файла и нажмите ОК.

Ваша новая таблица откроется с правами на редактирование и новым разделом в меню — «Получить данные CoMagic». Если на панели этот раздел не появился, нажмите F5.


  • Введите токен Data API пользователя. Чтобы получить токен, перейдите в личный кабинет: CoMagic → Администратор → Управление пользователями → Выбрать пользователя (под которым будете использовать коннектор).

  • В настройках пользователя включите «Доступ к функциональности API» и получите ключ.
  • Полученный ключ скопируйте.
  • Перейдите обратно в созданную вами таблицу Google Sheets. Выберите «Инструменты → Редактор скриптов».

Откроется скрипт Data_Api to Sheets, перейдите в раздел «Файл → Свойства скрипта».


  • Перейдите во вкладку «Свойства скрипта».
  • Введите новое свойство access_token и скопируйте в «Значение» токен Data API из настроек пользователя. Нажмите «Сохранить».
  • Закройте вкладку скрипта. Если вы все сделали правильно, она больше не понадобится.
  • Перейдите в файл Google Sheets в раздел «Получить данные CoMagic → Получить звонки».

  • На данном этапе Google попросит пройти авторизацию.

Нажмите «Продолжить».

В следующем окне выберите нужный аккаунт Google.

В следующем окне перейдите в «Дополнительные настройки»

и нажмите на «Перейти на страницу "Data_Api to Sheets" (небезопасно)».

Приложение запросит разрешение.

Нажмите «Разрешить».

  • Снова перейдите в раздел «Получить данные CoMagic → Получить звонки».

Построится таблица с данными по звонкам.

При этом вы всегда сможете изменить дату, введя новое значение в полях даты.

После изменения даты нужно перейти в раздел «Получить данные CoMagic → Получить звонки». Тогда данные загрузятся за период, который вы ввели руками.

Теперь вы сможете обработать полученные данные, проанализировать и визуализировать их.

Для получения других отчетов просто выберите их в разделе меню «Получить данные CoMagic». Желательно это делать в новом листе.

Обработка ошибок

В коннектор встроена обработка ошибок. Например, если вы запросите данные более чем за 90 дней, то получите подобный ответ:

Нажмите OK, измените период и попробуйте еще раз.

Если вы пытаетесь получить доступ с IP, не занесенного в белый список, то получите ошибку с указанием IP, который нужно добавить в такой список.


Перейдем к тому, как визуализировать полученные данные в Google Data Studio, Power BI и как загрузить данные в Excel.

Подключение к таблице через PowerBI

Итак, у вас есть данные в Google Sheets. Для визуализации можно воспользоваться стандартными графиками таблиц Google, которые закроют больше 80% задач. Однако если требуется визуализировать данные в Power BI, воспользуйтесь инструкцией:

  • Предоставьте доступ к вашему файлу Google Sheets на просмотр через ссылку. Скопируйте ссылку.

  • Откройте приложение PowerBI Desktop и нажмите «Получить данные → Интернет».

  • Укажите скопированный URL на предыдущем шаге

https://docs.google.com/spreadsheets/d/XXXXXXXXXXXXXXXXXXXXXX/edit?usp=sharing

и модифицируйте его: удалите часть edit?usp=sharing и замените на export.

Итоговый вид ссылки должен быть таким:

https://docs.google.com/spreadsheets/d/XXXXXXXXXXXXXXXXXXXXXX/export

  • Выберите нужный лист и нажмите кнопку «Преобразовать данные».

  • В редакторе запросов Power Query удалите ненужные строки и добавьте заголовок.

  • Теперь ваши данные в Power BI. Если обновить данные в Google Sheets, они подтянутся в ваш отчет в Power BI.


Подключение к таблице через Google Data Studio

Теперь расскажем, как передавать данные в Google Data Studio.


  • Подготовьте таблицу: выберите нужный период, загрузите данные и скройте верхние строки, в которых меняли период.
  • Откройте сервис Google Data Studio, создайте пустой отчет и нажмите на «Создать источник данных».

  • Найдите готовый коннектор Google Таблицы и нажмите «Выбрать».

  • Выберите таблицу и нужный лист. Отмените опцию «Включить скрытые и отфильтрованные ячейки» и укажите диапазон отчета, который хотите загрузить.


Например, для отчета «Звонки» это A3:AU.

  • Нажмите кнопку «Связать» и получите список доступных параметров из отчета.

  • Нажмите кнопку «Добавить к отчету».
  • Теперь ваши данные в Google Data Studio.


Преимущество данного подхода — в экономии баллов API. Соединение через Google Sheets позволяет один раз получить данные по Data API, подготовить их, обработать и потом уже передать в Google Data Studio.

Подключение к таблице через Excel

Многие компании используют в своей отчетности инструменты пакета Microsoft Office. Несмотря на все плюсы Google Sheets, Microsoft Excel по-прежнему популярен на рынке десктопных офисных приложений по работе с электронными таблицами. Поэтому покажем, как получать данные из нашего коннектора Google Sheets в Microsoft Excel. В примере будем использовать Microsoft Excel 2016.

  • Предоставляем доступ к нашему файлу Google Sheets на просмотр через ссылку. Копируем ссылку.

  • Откройте приложение Microsoft Excel и нажмите на «Данные → Создать запрос → Из других источников → Из Интернета».

  • Укажите скопированный URL на предыдущем шаге.

https://docs.google.com/spreadsheets/d/XXXXXXXXXXXXXXXXXXXXXX/edit?usp=sharing

и модифицируйте его: удалите часть edit?usp=sharing и замените на export.

Итоговый вид ссылки должен быть таким:

https://docs.google.com/spreadsheets/d/XXXXXXXXXXXXXXXXXXXXXX/export


  • Предоставьте доступ к веб-содержимому.

  • Выберите нужный лист и нажмите кнопку «Изменить».

  • В редакторе запросов Power Query удалите ненужные строки.

  • Добавьте заголовок.

  • Ваши данные — в Microsoft Excel.


Подключение к таблице через Tableau

Tableau — одни из родоначальников систем по визуализации данных. Покажем, как подключиться к Google Sheets с помощью этого инструмента.


  • Запустите Tableau Desktop и выберите в качестве источника данных Google Sheets.

  • Предоставьте доступ приложению Tableau к вашему Google-аккаунту.

  • Выбираем нашу таблицу и нажимаем Connect.

  • После выполнения запроса вы увидите список листов в таблице. Выберите нужный.
  • Обязательно включите опцию Use Data Interpreter, чтобы убрать поля выбора дат и сформировать заголовок таблицы.

  • Поправьте формат данных в нужных полях. Например, чтобы корректно отобразить поле ID, измените его на Number.

  • Готово. Дальше можете работать в своем любимом инструменте.


Подключение к таблице через QlikView

QlikView — очень распространенный инструмент в России.

Покажем, как можно подключиться к Google Sheets-таблице с помощью него.

  • Предоставьте доступ к вашему файлу Google Sheets на просмотр через ссылку. Скопируйте ссылку.

  • Откройте приложение QlikView и нажмите на «Редактор скрипта» на панели инструментов.

  • Далее в окне «Редактора скрипта» выберите опцию «Web-файлы».

  • Укажите скопированный URL на предыдущем шаге

https://docs.google.com/spreadsheets/d/XXXXXXXXXXXXXXXXXXXXXX/edit?usp=sharing

и модифицируйте его: удалите часть edit?usp=sharing и замените на export.

Итоговый вид ссылки должен быть таким:

https://docs.google.com/spreadsheets/d/XXXXXXXXXXXXXXXXXXXXXX/export

Нажмите «Далее».

  • Произведите настройку представления данных. Выберите «Размер — линий, 2. Метки — Встроенные метки» (чтобы поднять заголовок).

Нажмите «Готово → Ок».

  • Теперь можно загрузить данные

и дождаться выполнения скрипта.

  • Данные получены, вы можете их визуализировать.


Подключение к таблице через QlikSense

QlikSense — удобный инструмент анализа для аналитиков без особой подготовки. Покажем, как можно подключиться к нашей Google Sheets-таблице с помощью этого инструмента.

  • Создайте новый лист и выберите «Создать новое подключение».

  • Выберите источник данных Google Drive & Spreadsheets.

  • Нажмите Authenticate.

Разрешите доступ к аккаунту, где лежит файл Google Sheets.

  • Скопируйте полученный код.

  • Вставьте его в окно Authenticate, нажмите Verify.

  • Нажмите «Создать».

  • Зайдите в редактирование коннектора.

  • Перейдите в раздел GetSheetValues.

Введите Spreadsheet Key (берем его из URL таблицы).

  • Остальные поля заполните, как на скриншоте ниже, и нажмите Preview data. Если все ввели правильно, появятся данные:

  • После этого выберите нужные столбцы и нажмите «Вставить скрипт».

  • Нажмите «Загрузить данные»

и перейдите на вкладку «Анализ».

Достаточно выбрать один параметр, и QlikSense все построит за вас!

Эта статья была полезна для 9 людей. Эта статья помогла Вам?

Сервис поддержки клиентов работает на платформе UserEcho